Author Topic: ice auger will not stay running unless you keep priming it jiffy 30  (Read 4436 times)

kchamp

  • Team IceShanty Addict
  • *
  • Posts: 776
I have a jiffy model 30 ice auger, it will not stay running unless you keep priming it, I cleaned the carb and didn`t find anything wrong with it, put fresh gas in it after draining all the lines, put a new primer ball on it and its still is starving for fuel, I can get to run if I leave the choke all the way on but as soon as I take the choke of it dies out unless you keep priming it

Lobes

  • Team IceShanty Maniac
  • **
  • Posts: 3,658
  • Just Fishin'
Is the air filter clean? Is there a shut off for the fuel?

                              :tipup:
NBG

Mecosta County / Lakeview, Michigan

Icecracka46

  • Team IceShanty Addict
  • *
  • Posts: 634
  • My favorite fishing partner
loo in mass general.Someone posted a great illustration on how to work on jiffy's.
good luck

 

kchamp

  • Team IceShanty Addict
  • *
  • Posts: 776
no fuel shut off, just vent on top off the gas tank, and does not have a air filter on it, it also only has one carb adjustment on it, does any body know the number of turns to set this at

FishinIsLife

  • Team IceShanty Regular
  • ***
  • Posts: 121
don't prime it, without it running pull the choke on full, take the intake cover plate off so you can see down the carb throat, with the on/off switch off keep pulling it over maybe 20 times. open the choke and see if there is a puddle of gas in the belly of the carb if there isn't then either the fuel line is clogged or the jet on the carb is plugged. Assuming no puddle of gas, take the fuel line of the carb hold it down dump some gas in the tank if it comes out the line it isn't clogged and take your carb back apart get some carb cleaner and compressed air. Then try her again. If that still dont work maybe the rings are bad and she just can't suck fuel in. pull out the plug put your thumb on the hole have someone pull if over if it is at all easy to keep your thumb over the hole you don't have enough compression.

Gill-N-Time

  • IceShanty Rookie
  • **
  • Posts: 14
sounds like a diaphragm to me! It should be on the bottom of the carb. I just replaced mine.

newbraintree

  • Team IceShanty Maniac
  • **
  • Posts: 2,021
  • Get a Set!

Have you replaced the gas lines and spark plug?  Also, take the carb off and soak it in Gumout
, , ,

kchamp

  • Team IceShanty Addict
  • *
  • Posts: 776
Thank you guys for all the help, I have another carb from a different Jiffy auger same model but this one has a high and low speed jet so I used the mass. general auger post to set, put it on and it runs great it must be the jet or the diaphragm in the carb

 


Follow Iceshanty at Twitter Iceshanty Facebook Page Iceshanty Youtube Channel
Iceshanty | MyFishFinder | MyHuntingForum
Contact | Disclaimer | Privacypolicy | Sponsor
© 1996- Iceshanty.com
All Rights Reserved.