Author Topic: Marcum LX-6 problems  (Read 2240 times)

Offline Thearcher1340

  • Team IceShanty Regular
  • ***
  • Posts: 391
Re: Marcum LX-6 problems
« Reply #30 on: Jan 18, 2018, 06:47 PM »
Love my marcum son LX5,LX6,LX7

Offline 3300

  • Iceshanty Militia
  • Team IceShantyholic
  • *
  • Posts: 7,094
  • Not affiliated with MarCum Tech.
Re: Marcum LX-6 problems
« Reply #31 on: Jan 18, 2018, 07:23 PM »
thanks for the update! glad it was a worn out battery.
like marcum says 90% of sonar issues are battery related.

Offline Icefisher40

  • Team IceShanty Maniac
  • **
  • Posts: 1,787
  • Missing the U.P
Re: Marcum LX-6 problems
« Reply #32 on: Jan 19, 2018, 11:59 AM »
I was hoping that battery was the cause of my issues too, but I was one of the unfortunate 10%.

-Replaced bad resistor on mother board affecting ducer signal.
-Replaced bad transistor on mother board affecting lights on display.

Was glad to finally have it back after a while without it. Appears to be fine now.

Offline Scout 24

  • IceShanty Rookie
  • **
  • Posts: 41
Re: Marcum LX-6 problems
« Reply #33 on: Jan 31, 2018, 02:28 PM »
How true it is when big corporations buy out smaller top notch companies, cs always goes to crap. I was on the phone yesterday with Navionics for 50 minutes just to get to talk with a real person. Garmin bought them out in October. Got through to Lowrance today in 3 minutes, that was a record. I always thought Marcum was one of the good ones till I cut the camera cord of my vs625. I called and found they can't splice it back together, that'll be $285, plus $20 for shipping. My fault, OK. Got the camera but they sent the wrong circuit board to attach it to. Shipped the whole thing back to Marcum. Got a call from them, another $100+shipping for a new front panel board as well. I'm in so deep, so go ahead. Took it out for the first time a month ago. The display doesn't stay on unless I hold down the on/off button. Also a small bb sized projection is is coming through the front on/off panel that they replaced. I've got over another $500 in a unit that I think I paid $550 for new. I'm looking at Aqua View and maybe Vexilar to replace it, at least I know I'll get good service.

Offline Scout 24

  • IceShanty Rookie
  • **
  • Posts: 41
Severely disappointed in Marcum Customer Service!
« Reply #34 on: Jan 31, 2018, 02:31 PM »
How true it is when big corporations buy out smaller top notch companies, cs always goes to crap. I was on the phone yesterday with Navionics for 50 minutes just to get to talk with a real person. Garmin bought them out in October. Got through to Lowrance today in 3 minutes, that was a record. I always thought Marcum was one of the good ones till I cut the camera cord of my vs625. I called and found they can't splice it back together, that'll be $285, plus $20 for shipping. My fault, OK. Got the camera but they sent the wrong circuit board to attach it to. Shipped the whole thing back to Marcum. Got a call from them, another $100+shipping for a new front panel board as well. I'm in so deep, so go ahead. Took it out for the first time a month ago. The display doesn't stay on unless I hold down the on/off button. Also a small bb sized projection is is coming through the front on/off panel that they replaced. I've got over another $500 in a unit that I think I paid $550 for new. I'm looking at Aqua View and maybe Vexilar to replace it, at least I know I'll get good service.

Offline mee2gofishing

  • IceShanty Rookie
  • **
  • Posts: 9
Re: Marcum LX-6 problems
« Reply #35 on: Apr 05, 2019, 09:29 AM »
Interesting that so much focus was on the battery.  I had the very same issue occur to my Lx-6s after using 6 or 7 days with the Marcum Lithium Ion Shuttle.  The unit turns on, will work fine in simulation mode, but will often be frozen or become frozen when using it on the ice.  It happened first when the shuttle was 87% charged, but also occurred several times when the shuttle was fully charged.  Ducer clicks and on a couple of occasions the sonar worked for a very short time before the unit froze. 

I was guessing a bad ducer, but this is my second season with it.  It hasn't been abused at all. In fact it really hasn't seen a full season.  Replaced it with a Helix Ice unit, but this unit won't mount of the Marcum shuttle and chews through batteries. 

Offline 3300

  • Iceshanty Militia
  • Team IceShantyholic
  • *
  • Posts: 7,094
  • Not affiliated with MarCum Tech.
Re: Marcum LX-6 problems
« Reply #36 on: Apr 05, 2019, 11:15 AM »
Interesting that so much focus was on the battery.  I had the very same issue occur to my Lx-6s after using 6 or 7 days with the Marcum Lithium Ion Shuttle.  The unit turns on, will work fine in simulation mode, but will often be frozen or become frozen when using it on the ice.  It happened first when the shuttle was 87% charged, but also occurred several times when the shuttle was fully charged.  Ducer clicks and on a couple of occasions the sonar worked for a very short time before the unit froze. 

I was guessing a bad ducer, but this is my second season with it.  It hasn't been abused at all. In fact it really hasn't seen a full season.  Replaced it with a Helix Ice unit, but this unit won't mount of the Marcum shuttle and chews through batteries.

i would have tried flashing it before giving up on it. doesn't cost a thing to do it. then, i would have sent it in after talking with marcum explaining the situation and allow them to make it right if resetting the unit with a flash/firmware reset didn't take care of it.

too late now tho.

maybe make a bracket to fit the shuttle. kinda surprised you didn't sell the shuttle with the marcum.

 



Follow Iceshanty at Twitter Iceshanty Facebook Page Iceshanty Youtube Channel
Iceshanty | MyFishFinder | MyHuntingForum
Contact | Disclaimer | Privacypolicy | Sponsor
© 1996- Iceshanty.com
All Rights Reserved.