Author Topic: Helix Problem  (Read 219 times)

Offline JMZ

  • Iceshanty Militia
  • Team IceShanty Addict
  • *
  • Posts: 662
  • AKA Dinkmaster
Helix Problem
« on: Feb 25, 2021, 10:42 PM »
(Updated request)
I converted a Helix 10 G3 for ice fishing. The ice conversion unit power cable bought thru HB connects directly to the battery. The Lithium battery pushes 10a.
I also connected a hum Mega 360 to the same battery. Hum provided a power cable for it with open wires. I wrapped them around the battery terminals to use the Helix with the Mega 360. It uses a lot of power and the battery dies after about 4 hr.

I had no problems this year, but the unit fell off a bucket yesterday. It worked Ok afterward, but today it won't turn on. The battery shows charged. The Helix without the Mega 360 seems to be connected with the multi-connection clip.

Has anyone had any similar problems?
AKA Dinkmaster

Offline sparksNfishing

  • Team IceShanty Regular
  • ***
  • Posts: 141
Re: Helix Problem
« Reply #1 on: Feb 26, 2021, 07:41 AM »
That sucks.  :(
I'm not sure what size of conductor connects the helix to the battery on your unit but if it's the same as my helix 5 it's only about a #20 wire, maybe #18. Which is only rated for around ~8amps. I wouldn't think you burnt the conduct out but maybe damaged it with it falling. Could be a damaged connector so a quick ohm/beep test should tell you if it is.
I would assume there is an internal voltage regulator and protection that may of let smoke out if your 12v leads shorted out. That would require opening the unit to check and probably would want to speak with Humminbird about that. If Humminbird won't warranty but you have a good electronics shop near by that would be your best bet to fix something electrical.

Offline JMZ

  • Iceshanty Militia
  • Team IceShanty Addict
  • *
  • Posts: 662
  • AKA Dinkmaster
Re: Helix Problem
« Reply #2 on: Feb 26, 2021, 01:05 PM »
(Updated request)
I converted a Helix 10 G3 for ice fishing. The ice conversion unit power cable bought thru HB connects directly to the battery. The Lithium battery pushes 10a.
I also connected a hum Mega 360 to the same battery. Hum provided a power cable for it with open wires. I wrapped them around the battery terminals to use the Helix with the Mega 360. It uses a lot of power and the battery dies after about 4 hr.

I had no problems this year, but the unit fell off a bucket yesterday. It worked Ok afterward, but today it won't turn on. The battery shows charged. The Helix without the Mega 360 seems to be connected with the multi-connection clip.

Has anyone had any similar problems?

I think I found the problem, bad Dakota 12v, 10a battery; only 2 yrs old. I think I maxed out the amp amount and now it only charges to 9v. I'm calling Dakota. I ordered a Dakota 12v, 23a; it should handle the load.
AKA Dinkmaster

 



Iceshanty | MyFishFinder | MyHuntingForum
Contact | Disclaimer | Privacypolicy | Sponsor
© 1996- Iceshanty.com
All Rights Reserved.